Announcement

Collapse
No announcement yet.

Ravenheat combi boiler

Collapse
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ravenheat combi boiler

    After the central heating has been started either manually or through the timer and after it has reached its set temp it turns off but will not reignite until you turn the power off altogether then switch it back on.The red ignition indication light comes on telling you "no ignition".The boiler is a Ravenheat combi LS 80T

  • #2
    Sounds like the themisters!!! chances are that they are caked up with magnatite so you may get away eith cleaning them off but its always better to replace them!

    Comment


    • #3
      Thanks for your reply will have a look

      Comment


      • #4
        engineer tested thermisters ok says it could be gas valve or pump but doesen't really know, after closing down last night ignition light was flashing hence no ch this morning I turned off power moved timer to advanced put power back on pressed ignition it has now been working for an hour on low heat boiler control,any further suggestions apart from a new boiler ,new pcb 4 months ago

        Comment


        • #5
          The only thing i can think of it being is the water not clearing from the boiler. I would check circulation, pump, or a dreaded pcb!!!! The only reasons that i have had when it doesn't fire back up was because of the themisters and sludged system. Look at how much on parts and labour you have spent and see how you feel! Even if you don't have enough cash to get a new boiler it may pay to put one on the credit card or credit card cheque! Just an idea!! It's hard to diagnose faults when not on site! How old is the boiler? How dirty is your system water? Is it a condensing? If it is, you may find that the main heat ex is scaled up!!

          Comment


          • #6
            The boiler was installed in 2004 ,its got relatively clean water as I added two rads some months ago ,your probably right it could be umpteen things wrong a new boiler may be the answer

            Comment


            • #7
              Engineer sorted it yesterday replaced thermister control stat and pump - working fine 240-00p incl vat.Thanks for your input appreciated.

              Comment

              Working...
              X