Announcement

Collapse
No announcement yet.

ariston microgenus 27 mffi boiler keeps shutting off..

Collapse
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ariston microgenus 27 mffi boiler keeps shutting off..

    Hi Guys,

    Im having an issue with the above boiler and would be very grateful if anyone could shed some light on it.

    Wether its hot water usage,thermostat/timer or manual use,The boiler fires up for about 3 seconds then shuts off.The pump keeps on running and i get a red error led but the boiler is no longer heating.This happens probably 6-7 times out of 10 when the boiler comes on.

    https://i983.photobucket.com/albums/...-01-12_315.jpg

    The above photo shows the led lit.If i press the reset button the boiler fires up and runs fine (sometimes have to press the reset button a couple of times),but can also shut off again after half an hour or so,or if i try using hot water while its running.

    First thing i did was try the X800 and X400 chemicals from screwfix for just over a week in the system with no joy.I then had the heat exchange removed and descaled.My rads are now hotter but boiler is still showing the same fault.

    There are no strange noises when the boiler is running.Pressure is around 1bar normally and just under 2 while running.(ive tried lower and slightly higher pressure to the same end).I believe the boiler was fitted around 2000.

    Any ideas guys?

    thanks!
Working...
X