Announcement

Collapse
No announcement yet.

Viessmann Vitodens 100W - WB1B, F2 temperature limiter fault

Collapse
  • If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Viessmann Vitodens 100W - WB1B, F2 temperature limiter fault

    Over the last couple of months the boiler has stopped 3 or 4 times with an F2 error code.
    Usually it is first thing in the morning, or in the really cold spell, when the frost stat kicked in during the early hours. I have begun to recognise the symptoms as radiators cold, but pump running continuously, and pipes into the pump also cold.

    According to the service booklet, F2 is a "temperature limiter" error, and the things to check are:
    •system level full
    •circulation pump working
    •temperature limiter and wiring.

    I have checked the system level, and I know the pump is running, but the pump is very likely the original pump and getting on for 30 years old. It's a Grundfos something, but I am wondering about its efficiency, since the furthest radiator does take a while to get hot.

    On reset, the boiler display changes from "F2" flashing, to "141", followed by "115degC", then normal operation resumes.

    I'd be grateful for any ideas.
    Thanks!

  • #2
    sounds like a circulation problem possible pump/air lock or could be a flow switch/sensor my first thought would be air lock presuming the pump is running.

    Comment

    Working...
    X